Aufgaben: kleiner Ausblick auf die nächsten Versionen -> Tschüss, XP!

Windows XP wird nun seit über einem Jahr nicht mehr von Microsoft mit Sicherheitsupdates versorgt. Die Firma Adobe stellt die neueste Version des Adobe Readers DC nicht mehr für WIndows XP und Windows Vista zur Verfügung. Nun wird auch Aufgaben einen Schnitt machen und alte Zöpfe abschneiden.

Die in Kürze kommende Version 1.4.2.0 wird die letzte Version sein, die für Windows XP bereitgestellt wird. Neuere Versionen werden sich unter Windows XP nicht mehr installieren oder nutzen lassen. Mit dem Update 1.4.2.0 wird jedoch ein letztes Mal ein Fehler behoben, der nur unter Windows XP auftritt (wegen Nutzung von Systemfunktionen, die es nur unter XP gibt).

Das Update 1.4.2.0 ist für alle anderen Windows-Systeme (Vista, Windows 7, Windows 8, Windows 8.1 und Windows 10) Voraussetzung, dass weitere Updates automatisch installiert werden können, da mit dieser Version das Updateverfahren geändert wird.

Ab der Version 1.5.0.0 ist dann das Microsoft .Net Framework Version 4.0 erforderlich. Durch Nutzung des neueren Frameworks ist Aufgaben stabiler, zudem können bei der Weiterentwicklung neue Features genutzt werden, durch die die Entwicklung einfacher wird.